HDU2319— Card Trick

最近才看的STL—vector,所以就练练手手,写了一道类似的题。 ## 题目:J - Card Trick

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1.The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
2.Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
3.Three cards are moved one at a time…
4.This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

Input

On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.

Output

For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…

Sample Input

2
4
5

Sample Output

2 1 4 3
3 1 4 5 2

解题思路:

利用尾插法先把第一个数n输入进去,当输出的数组的长度不满足n时执行一下循环:把第n-i个数放在头部,把最后一个数放在头部,删除尾部的数,每一次循环让i++;

注意:最后一个尾数没有空格。

程序代码:

#include<vector>
#include<iostream>
using namespace std;
int main()
{
	vector<int> v;
	int i,n,m,k,b;
	cin>>k;
	for(int j=1;j<=k;j++)
	{
		cin>>n;
		v.push_back(n);
		i=1;
		while(v.size()!=n)
		{
			v.insert(v.begin(),n-i);
			m=n-i;
			while(m--)
			{
				v.insert(v.begin(),*(v.end()-1));
				v.erase(v.end()-1);
			}
			i++;	
		}
		for(i=0;i<n-1;i++)
			cout<<v[i]<<" ";
		cout<<v[n-1];
		cout<<endl;
		v.clear();	
	}
	return 0;
} 
 

vector用法不懂的可以参照上一篇博客

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

我菜就爱学

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值