hdu 2319

Card Trick

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 332    Accepted Submission(s): 165


Problem Description
The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

1.The top card is moved to the bottom of the pack. The new top card is dealt face up onto the table. It is the Ace of Spades.
2.Two cards are moved one at a time from the top to the bottom. The next card is dealt face up onto the table. It is the Two of Spades.
3.Three cards are moved one at a time…
4.This goes on until the nth and last card turns out to be the n of Spades.
This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.
 

Input
On the first line of the input is a single positive integer, telling the number of test cases to follow. Each case consists of one line containing the integer n.
 

Output
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
 

Sample Input
  
  
2 4 5
 

Sample Output
  
  
2 1 4 3 3 1 4 5 2
 

Source

Nordic 2006

用队列来循环,逆行思维,从最后一个数a开始放置,然后a-i,循环放置,最后将这个队列中的元素按顺序输出即可。


#include<bits/stdc++.h>
using namespace std;
int main()
{
    int n,b[15],t,a;
    queue<int>Q;
    scanf("%d",&n);
    while(n--)
    {

        cin>>a;
        Q.push(a);
        for(int i=1; i<a; i++)
        {
            Q.push(a-i);
            for(int j=a-i; j>=1; j--)
            {
                t=Q.front();
                Q.pop();
                Q.push(t);
            }
        }
        int p=0;
        while(!Q.empty())
        {
            b[p]=Q.front();
            Q.pop();
            p++;
        }
        for(int i=p-1; i>=1; i--)
        {
            cout<<b[i]<<" ";
        }
        cout<<b[0]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值