POJ - 3259 Wormholes (spfa,负权回路)

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题意

F 组数据,N 个点,M条无向边,从S 到 E 花费的时间 T,W条单向虫洞(负权边),判断是否能回到出发以前。

思路

直接用spfa判断断一下。

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;

int n,m,w,dis[510],vis[510],bk[510];
int g,frt[510],next[5300],v1[5300],v2[5300],v3[5300];
void add(int x,int y,int z)
{
    v1[g]=x,v2[g]=y,v3[g]=z;
    next[g]=frt[v1[g]];
    frt[v1[g]]=g;
    g++;
}

queue<int>Q;
int spfa(int sr)
{
    memset(bk,0,sizeof(bk));
    memset(vis,0,sizeof(vis));
    memset(dis,inf,sizeof(dis));
    bk[sr]=1;
    vis[sr]=1;
    dis[sr]=0;
    Q.push(sr);
    while(!Q.empty())
    {
        int u=Q.front();
        vis[u]=0;
        Q.pop();
        for(int i=frt[u]; i!=-1; i=next[i])
        {
            //printf("+++++ %d %d %d %d\n",i,v1[i],v2[i],v3[i]);
            if(dis[v2[i]]>dis[u]+v3[i])
            {
                dis[v2[i]]=dis[u]+v3[i];
                if(vis[v2[i]]==0)
                {

                    vis[v2[i]]=1;
                    bk[v2[i]]++;
                    if(bk[v2[i]]>n)
                        return 1;
                    Q.push(v2[i]);
                }
            }
        }
    }
    return 0;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        g=0;
        int i,j,k,t1,t2,t3,fg=0;
        memset(frt,-1,sizeof(frt));
        scanf("%d%d%d",&n,&m,&w);
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            add(t1,t2,t3);
            add(t2,t1,t3);
        }
        for(i=0; i<w; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            add(t1,t2,-t3);
        }
        fg=spfa(1);
        if(fg) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值