Codeup——596 | 问题 A: Course List for Student (25)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

输入

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students Ni (<= 200) are given in a line. Then in the next line, Ni student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

输出

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

样例输入

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

样例输出

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

思路:统计每个学生所选的课程数,然后计算每个学生选了多少个课程数以及他们所选的课程数。这里可以用hash的思想,将学生的姓名转换成唯一的整数,然后在把他们所选的课程数放入vector中,具体代码如下。

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=26*26*26*10+1;	//3个大写字母和1个数字
vector<int> stu[maxn];	//用于存放每个学生的所选课程

int hashFunc(char s[]){	//字符串hash
	int id=0;
	for(int i=0;i<3;i++)
		id=id*26+(s[i]-'A');
	id=id*10+(s[3]-'0');
	return id; 
} 

int main()
{
	char name[5];
	int n,m,course,people,i,j,index;
	scanf("%d%d",&n,&m);	//输入学生人数和课程数
	for(i=0;i<m;i++){
		scanf("%d%d",&course,&people);	//课程代码和上课人数
		for(j=0;j<people;j++){
			scanf("%s",name);	//学生姓名
			stu[hashFunc(name)].push_back(course);	//hash转型,将字符串转换成唯一的整数,并把课程代码放入vector中
		}
	}
	for(i=0;i<n;i++){
		scanf("%s",name);	//输出n个学生的姓名
		index=hashFunc(name);	//找到散列之后的数组下标
		printf("%s %d",name,stu[index].size());
		sort(stu[index].begin(),stu[index].end());	//递增排序
		if(stu[index].size()){	//如果选课的课程数不为0
			for(j=0;j<stu[index].size();j++)
				printf(" %d",stu[index][j]);
		}
		printf("\n");
	}
	return 0;
}
以下是实现该类的Python代码: ```python from typing import List class Person: def __init__(self, name: str, email: str): self.name = name self.email = email def get_info(self) -> str: return f"Name: {self.name}\nEmail: {self.email}" class Student(Person): def __init__(self, name: str, email: str): super().__init__(name, email) self.courses = [] def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) def get_courses(self) -> List[str]: return [course.name for course in self.courses] def get_info(self) -> str: return f"{super().get_info()}\nCourses: {', '.join(self.get_courses())}" class Teacher(Person): def __init__(self, name: str, email: str): super().__init__(name, email) self.courses = [] def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) def get_courses(self) -> List[str]: return [course.name for course in self.courses] def get_info(self) -> str: return f"{super().get_info()}\nCourses: {', '.join(self.get_courses())}" class Admin: def __init__(self): self.students = [] self.teachers = [] self.courses = [] def add_student(self, student: Student): self.students.append(student) def remove_student(self, student: Student): self.students.remove(student) def add_teacher(self, teacher: Teacher): self.teachers.append(teacher) def remove_teacher(self, teacher: Teacher): self.teachers.remove(teacher) def add_course(self, course): self.courses.append(course) def remove_course(self, course): self.courses.remove(course) class Course: def __init__(self, name: str, teacher: Teacher): self.name = name self.teacher = teacher self.students = [] def add_student(self, student: Student): self.students.append(student) def remove_student(self, student: Student): self.students.remove(student) def get_info(self) -> str: return f"Name: {self.name}\nTeacher: {self.teacher.name}\nStudents: {[student.name for student in self.students]}" # Example Usage admin = Admin() teacher = Teacher("John Smith", "john.smith@example.com") course = Course("Math", teacher) student = Student("Jane Doe", "jane.doe@example.com") admin.add_teacher(teacher) admin.add_student(student) admin.add_course(course) course.add_student(student) teacher.add_course(course) student.add_course(course) print(student.get_info()) print(teacher.get_info()) print(course.get_info()) ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值