Sudoku

Sudoku

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.
在这里插入图片描述

Input
The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.
Output
For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.
Sample Input
1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107
Sample Output
143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127
思路:
深度优先搜素,用三个数组分别标记行,列,九宫格,保证在同一行,同一列或和同一九宫格中出现1至9,并且没有重复数字

int book1[10][10]={0};//标记行
int book2[10][10]={0};//标记列
int book3[10][10]={0};//标记九宫格

判断在哪一个九宫格,为了使代码简练,可以写一个函数来判断

int jiugongge(int x,int y){
    int k;
    if(1<=x&&x<=3&&1<=y&&y<=3) k=1;
    else if(1<=x&&x<=3&&3<y&&y<=6) k=2;
    else if(1<=x&&x<=3&&6<y&&y<=9) k=3;
    else if(3<x&&x<=6&&1<=y&&y<=3) k=4;
    else if(3<x&&x<=6&&3<y&&y<=6) k=5;
    else if(3<x&&x<=6&&6<y&&y<=9) k=6;
    else if(6<x&&x<=9&&1<=y&&y<=3) k=7;
    else if(6<x&&x<=9&&3<y&&y<=6) k=8;
    else if(6<x&&x<=9&&6<y&&y<=9) k=9;
    return k;
}//确定处于哪一个九宫格

完整代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int book1[10][10]={0};//标记行
int book2[10][10]={0};//标记列
int book3[10][10]={0};//标记九宫格
int flag;
int maze[11][11];
int jiugongge(int x,int y){
    int k;
    if(1<=x&&x<=3&&1<=y&&y<=3) k=1;
    else if(1<=x&&x<=3&&3<y&&y<=6) k=2;
    else if(1<=x&&x<=3&&6<y&&y<=9) k=3;
    else if(3<x&&x<=6&&1<=y&&y<=3) k=4;
    else if(3<x&&x<=6&&3<y&&y<=6) k=5;
    else if(3<x&&x<=6&&6<y&&y<=9) k=6;
    else if(6<x&&x<=9&&1<=y&&y<=3) k=7;
    else if(6<x&&x<=9&&3<y&&y<=6) k=8;
    else if(6<x&&x<=9&&6<y&&y<=9) k=9;
    return k;
}//确定处于哪一个九宫格
int dfs(int x,int y){
    int k;
    flag=0;
    //cout<<"x="<<x<<endl;
    if(x==10){
        return 1;
    }
    if(maze[x][y]){
        if(y==9)
            flag=dfs(x+1,1);
        else   
            flag=dfs(x,y+1);
        if(flag==1)
            return 1;
        else 
            return 0;
    }
    else{
        for(int i=1;i<=9;i++){
            k=jiugongge(x,y);
            if(book1[x][i]==0&&book2[y][i]==0&&book3[k][i]==0){
                maze[x][y]=i;
                book1[x][maze[x][y]]=1;
                book2[y][maze[x][y]]=1;
                k=jiugongge(x,y);
                book3[k][maze[x][y]]=1;
                if(y==9)
                    flag=dfs(x+1,1);
                else   
                    flag=dfs(x,y+1);
                if(flag==1){
                    return 1;
                }
                else{
                    maze[x][y]=0;
                    book1[x][i]=0;
                    book2[y][i]=0;
                    k=jiugongge(x,y);
                    book3[k][i]=0;
                } 
            }
        }
    }
    return 0;
}
int main(void){
    int t,k;
    char ch;
    cin>>t;
    while(t--){
        memset(book1,0,sizeof(book1));
        memset(book2,0,sizeof(book2));
        memset(book3,0,sizeof(book3));
        for(int i=1;i<=9;i++)
            for(int j=1;j<=9;j++){
                cin>>ch;
                maze[i][j]=ch-'0';
                book1[i][maze[i][j]]=1;
                book2[j][maze[i][j]]=1;
                k=jiugongge(i,j);
                book3[k][maze[i][j]]=1;
            }
        dfs(1,1);
        for(int i=1;i<=9;i++){
            for(int j=1;j<=9;j++){
                cout<<maze[i][j];
            }
            cout<<endl;
        }
    }
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值