PAT 1051

题目

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

从 1 ~ N 入栈,给出栈的大小和要判断的可能的个数,要求判断给出的序列是否可以是合理的出栈序列

代码和思路

  1. 模拟出入栈过程,从 1 ~ N 入栈,如果当前的栈顶元素 temp 和给定序列元素 a[flag] 相同 ,则出栈,然后 flag++
  2. 跳出循环的条件需要加一个栈的容量超过了所给定的size
  3. 如果 1 ~ N 读入完毕后,栈內仍然有元素,则证明这个序列是不可行的,输出NO,反之输出YES
#include<cstdio>
#include<stack>
using namespace std;

int main() {
	int query, lenth, size;
	scanf("%d %d %d", &size, &lenth, &query);
	for (int i = 0; i < query; i++) {
		int a[1001];
		for (int k = 0; k < lenth; k++) {
			scanf("%d", &a[k]);
		}
		int flag = 0;
		stack<int> m;
		for (int l = 0; l < m.size(); l++) m.pop();
			for (int j = 1; j <= lenth; j++) {
			m.push(j);
			if (m.size() > size) break;
			int temp = m.top();
			while (temp == a[flag] && m.size() > 0) {
				flag++;
				m.pop();
				if (m.size() > 0) temp = m.top();
			}
		}
		if (m.size() != 0) printf("NO\n");
		else printf("YES\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值