PAT 1055

题目

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5) - the total number of people, and K (≤10​3) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−106​​ ,106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

给定一些人,包含了他们的年龄,名字和拥有的财富,给出一个年龄空间和要求的输出人数,要求根据财富的由高到低输出符合年龄范围的人的信息

代码和思路

  1. 按照所拥有的财富进行排序,但同时需要其余两个次关键字,分别是名字和年龄,财富是降序排列,次关键字是升序排列
  2. 遍历整个容器,判断这个人是否符合条件,符合的话输出,不符合的话跳过
  3. 时间复杂度为O(n*k);
#include<cstdio>
#include<string>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;
struct rich {
	string name;
	int age, networth;
	rich(string _name, int _age, int _networth) : name(_name), age(_age), networth(_networth){}
};


vector<rich> richman;
int n, k;
int casek = 1;

bool cmp(rich a, rich b) {
	if (a.networth != b.networth) {
		return a.networth > b.networth;
	}
	else if (a.age != b.age) {
		return a.age < b.age;
	}
	else
		return a.name < b.name;
}

void find_need(int needput, int low, int high) {
	cout << "Case #" << casek << ":" << endl;
	casek++;
	int index = 0;
	int sum = 1, flag = 0;
	while (sum <= needput && index < n) {
		if (richman[index].age >= low && richman[index].age <= high) {
			cout << richman[index].name << " " << richman[index].age << " " << richman[index].networth << endl;
			flag = 1;
			sum++;
		}
		index++;
	}
	if (flag == 0) printf("None");
	//else printf("\n");
}

int main() {
	string name;
	int age, networth;
	scanf("%d %d", &n, &k);
	for (int i = 0; i < n; i++) {
		cin >> name;
		scanf("%d %d", &age, &networth);
		richman.push_back(rich(name, age, networth));
	}
	sort(richman.begin(), richman.end(), cmp);
	int needput, low, high;
	for (int i = 0; i < k; i++) {
		scanf("%d %d %d", &needput, &low, &high);
		find_need(needput, low, high);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值