PAT甲级1046

1046 Shortest Distance (20 point(s))

题目原文

  The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
  Each input file contains one test case. For each case, the first line contains an integer N (in [3,10​5​​ ]), followed by N integer distances D1​​ D​2​ ⋯ D​N​​ , where Di​​ is the distance between the i-th and the (i+1)-st exits, and DN​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10​4​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10​7​​ .

Output Specification:
  For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

题目大意

  现在有一条环形高速公路,其中有N个出口,并给出相邻两个出口之间的距离,现在要求任意两个出口之间的最短距离

解题思路

  累加两个出口之间的距离,并判断是否超过总距离的一半,如果没有,则该距离为最小,否则用总距离减去该距离即为结果

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>

int dis[100010] = { 0 };
int main()
{
	int N, i, e1, e2, M;
	int ret = scanf("%d", &N);
	int sum = 0;
	for (i = 1; i <= N; ++i) {
		ret = scanf("%d", &dis[i]);
		sum += dis[i];
	}
	ret = scanf("%d", &M);
	for (i = 0; i < M; ++i) {
		ret = scanf("%d%d", &e1, &e2);
		if (e1 > e2) {
			int tmp = e1;
			e1 = e2;
			e2 = tmp;
		}
		int sum1 = 0;
		for (int j = e1; j < e2; ++j) {
			sum1 += dis[j];
		}
		
		printf("%d\n", sum1 > (sum - sum1) ? (sum - sum1) : sum1);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值