PAT甲级1058

1058 A+B in Hogwarts (20 point(s))

  If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:
  Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:
  For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

题目大意

  在哈利波特世界的货币系统下,输出两个金额之和

解题思路

  按进制求和即可,非常简单的一道题

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>

int main()
{
	int a[3], b[3], res[3];
	int ret = scanf("%d.%d.%d", &a[0], &a[1], &a[2]);
	ret = scanf("%d.%d.%d", &b[0], &b[1], &b[2]);
	res[2] = (a[2] + b[2]) % 29;
	res[1] = (a[1] + b[1] + (a[2] + b[2]) / 29) % 17;
	res[0] = a[0] + b[0] + (a[1] + b[1] + (a[2] + b[2]) / 29) / 17;
	for (int i = 0; i < 3; ++i) {
		if (i) printf(".");
		printf("%d", res[i]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值