PAT甲级1055(找出给定区间的前M名富人)

1055 The World’s Richest (25 point(s))

  Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:
  Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5) - the total number of people, and K (≤10​3) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6,10​6]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:
  For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

  The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目大意

  给出一张福布斯排行榜单,每项信息包括name,age,worth,随后给出K行要查询的年龄区间,要求你输出区间内的前M个富人信息

解题思路

  首先使用结构体存储每个富人的name,age,worth,并依照题目给定规则进行排序。随后每输入一条查询信息,就遍历输出符合条件的富人信息,同时记录已输出的富人数,保证不能超过M,遍历结束后,如果没有输出,则打印None

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct info {
	char name[10];
	int age;
	int worth;
}billionaires[100005];

bool cmp(info a, info b) {//排序规则
	if (a.worth != b.worth) return a.worth > b.worth;
	else if (a.age != b.age) return a.age < b.age;
	else return strcmp(a.name, b.name) < 0;
}

int main()
{
	int N, K, i, M, Amin, Amax;
	int ret = scanf("%d %d", &N, &K);
	for (i = 0; i < N; ++i) {
		ret = scanf("%s %d %d", billionaires[i].name, &billionaires[i].age, &billionaires[i].worth);
	}
	sort(billionaires, billionaires + i, cmp);
	for (i = 0; i < K; ++i) {
		ret = scanf("%d %d %d", &M, &Amin, &Amax);//输入最大个数,最小年龄和最大年龄
		printf("Case #%d:\n", i + 1);
		int cnt = 0;
		for (int j = 0; j < N; ++j) {
			if (cnt < M && billionaires[j].age >= Amin && billionaires[j].age <= Amax) {
				printf("%s %d %d\n", billionaires[j].name, billionaires[j].age, billionaires[j].worth);
				++cnt;//每输出一个
			}
		}
		if (!cnt) printf("None\n");//若没有符合条件的富人
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值