PAT甲级1067(用swap(0,*)排序)

1067 Sort with Swap(0, i) (25 point(s))

  Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:
Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

  Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
  Each input file contains one test case, which gives a positive N (≤10​5) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
  For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题目大意

  给定一个数字序列,0,1,2,…,N-1,每次只能用0与其他数字交换以排序,问最小次数是多少?

解题思路

  如果0不在首位,假设在i号位,就找到i所在位置,并交换0和i;如果0在首位,就随意选择一个不在本位的数字,并与0交换
注意:寻找一个不在本位上的数时,如果每次都从头开始寻找,会超时;最好定义一个变量,保存当前序列不在本位上的最小数

代码

#define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <algorithm>
using namespace std;

int arr[100005] = { 0 };
int main()
{
	int N, i, num, cnt = 0, n = 0;//n代表不在本位上的数字个数
	int ret = scanf("%d", &N);
	for (i = 0; i < N; ++i) {
		ret = scanf("%d", &num);
		arr[num] = i;//arr存储对应下标
		if (num != 0 && num != i) ++n;
	}
	int j = 1;
	while (n > 0) {
		if (arr[0] == 0) {//0在本位
			while (j < N) {//找到一个不在本位上的数字
				if (arr[j] != j) {
					swap(arr[0], arr[j]);
					++cnt;
					break;
				}
				++j;
			}
		}
		while (arr[0] != 0) {//0不在本位,就将0所在位置的数的位置与0所在位置交换
			swap(arr[0], arr[arr[0]]);
			++cnt;
			--n;//不在本位上的数少1
		}
	}
	printf("%d", cnt);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值