PAT甲级 A1067

PAT甲级 A1067

题目详情

1067 Sort with Swap(0, i) (25分)
Given any permutation of the numbers {0, 1, 2,…, N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}
Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:
Each input file contains one test case, which gives a positive N (≤10e5) followed by a permutation sequence of {0, 1, …, N−1}. All the numbers in a line are separated by a space.

Output Specification:
For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10
3 5 7 2 6 4 9 0 8 1
Sample Output:
9

解题思路

这道题我的思路比较特别,我才用了一个数组,数组的下标表示元素,数组的内容表示这个元素存储的位置。这样做的好处就是交换位置可以直接交换两个数组的内容。中间一直超时,后来发现是每次再0元素回到0点,选取交换时,每次都从头开始遍历,这样耗费大量时间,改成记录一个最新的错误节点就能解决超时的问题
以下为AC代码

#include<iostream>
#include<string>
#include<vector>
#include<cmath>
#include<memory.h>
#include<string>
#include<algorithm>
#include<iomanip>
#include<map>
#include<stack>
#include<queue>;
#include<set>;
#include<iterator>
using namespace std;
vector<int> qs;
int allno[100001];
int main() {
	int N; cin >> N;
	int notsame = 0;
	for (int i = 0; i < N; i++) {
		int temp;
		scanf_s("%d", &temp);
		qs.push_back(temp);
		if (temp != i) {
			notsame++;
		}
		allno[temp] = i;
	}
	int swapno = 0;
	int t = 0;
	while (true) {
		if (notsame == 0) {
			break;
		}
		if (allno[0] == 0) {
			for (int i = t; i < N; i++) {//随机获得一个不相符节点
				if (allno[i] != i) {
					swap(allno[0], allno[i]);
					swapno++;
					t = i;
					break;
				}
			}
		}
		else {
			swap(allno[0],allno[allno[0]]);
			swapno++;
			notsame--;
			if (notsame == 1 && allno[0] == 0) {
				notsame = 0;
			}
		}
	}
	cout << swapno << '\n';
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值