HDUOJ 2019数列有序!
Problem Description
有n(n<=100)个整数,已经按照从小到大顺序排列好,现在另外给一个整数x,请将该数插入到序列中,并使新的序列仍然有序。
Input
输入数据包含多个测试实例,每组数据由两行组成,第一行是n和m,第二行是已经有序的n个数的数列。n和m同时为0标示输入数据的结束,本行不做处理。
Output
对于每个测试实例,输出插入新的元素后的数列。
Sample Input
3 3
1 2 4
0 0
Sample Output
1 2 3 4
本题思路挺简单,就是用数组直接循环判断位置然后逐个把后面的元素往后移一位。
#include<stdio.h>
int main() {
int n, m, a[101], t;
while (~scanf("%d %d", &n, &m)) {
if (n == 0 && m == 0)
break;
for (int i = 0; i < n; i++)
scanf("%d", &a[i]);
for (int i = 0; i < n; i++) {
if (a[i] <= m && m <= a[i + 1])
t = i + 1;
}
for (int i = n - 1; i >= t; i--) {
a[i + 1] = a[i];
}
a[t] = m;
for (int i = 0; i < n; i++)
printf("%d ", a[i]);
printf("%d\n", a[n]);
}
return 0;
}