7-5 Shuffling Machine (20分)

Shuffling洗牌 is a procedure程序 used to randomize随机化 a deck of一副playing cards扑克牌. Because standard标准 shuffling techniques are seen as weak薄弱, and in order to avoid “inside jobs” where employees员工 collaborate合作 with gamblers by performing inadequate shuffles, many casinos赌场 employ采用 automatic 自动shuffling machines. Your task任务 is to simulate模拟 a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial初始 status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where “S” stands for “Spade黑桃”, “H” for “Heart”, “C” for “Club俱乐部”, “D” for “Diamond钻石”, and “J” for “Joker小丑”. A given order给定的顺序 is a permutation排列 of distinct不同 integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example,suppose假设 we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case测试用例. For each case情况, the first line contains a positive integer正整数 K (≤20) which is the number of repeat times重复次数. Then the next line contains the given order. All the numbers in a line are separated by a space用空格隔开.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

例如,假设我们只有5张卡:S3、H5、C1、D13和J2。给定洗牌顺序{4,2,5,3,1},结果将是:J2,H5,D13,S3,C1。如果我们再次重复洗牌,结果将是:C1、H5、S3、J2、D13。

#include <bits/stdc++.h>
using namespace std;

string ret[]={"",
"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
"H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
"C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
"D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
"J1","J2"};

int main(){
	int a[100]={0},b[100]={0},c[100]={0};
	int n; cin>>n; 
	
	for(int i=1;i<=54;i++){
		b[i]=i;  //1 2 3 4 5…… b[i]
		cin>>a[i]; //  输入的    a[i] 36 52 37 38
	} 
	while(n--){
		for(int i=1;i<=54;i++){
			c[a[i]]=b[i]; //c[36]=1,c[52]=2
		}
		memcpy(b,c,sizeof c);// 
		//void *memcpy(void *destin, void *source, unsigned n)
		//从源source中拷贝n个字节到目标destin中 
	}
	for(int i=1;i<=54;i++){
		if(i!=1)cout<<" ";
		cout<<ret[c[i]];
	} 
	return 0;
} 
  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

DDouble-

你的鼓励是我最大的动力~

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值