天梯赛—— 检查密码 (10 分)

传送门

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符非空字符串,以回车结束。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

Perception:

为什么要和我玩文字游戏啊啊啊啊!!!我没有脑子...     一直卡在第三组数据过不去,原因题目中说非空字符串,但是没说不让读入空格类字符啊~scanf显然不合适了~    

我想到一组数据

1
......

 这组数据,结果不管输出什么,都通过...我内心~~~~~~      我以为我卡到这组数据了...鬼知道读入方式问题... 不说了  我是菜鸡  

Code one:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main() {
	int n;
	cin>>n;
	getchar();
	for(int i=1; i<=n; i++) {
		int q1=0;///alphabet
		int q2=0;///num
		int q3=0;///.
		int q4=0;///no
		string a;
		getline(cin,a);
		int l=a.length();
		if(l<6)
			cout<<"Your password is tai duan le."<<endl;
		else {
			for(int j=0; j<l; j++) {
				if(a[j]<='9'&&a[j]>='0')
					q2=1;
				else if(a[j]<='z'&&a[j]>='a'||a[j]>='A'&&a[j]<='Z')
					q1=1;
				else if(a[j]=='.')
					q3=1;
				else q4=1;
			}
			if(q4)
				cout<<"Your password is tai luan le."<<endl;
			else if(q1&&!q2)
				cout<<"Your password needs shu zi."<<endl;
			else if(!q1&&q2)
				cout<<"Your password needs zi mu."<<endl;
			else if(q1&&q2&&!q4)
				cout<<"Your password is wan mei."<<endl;
		}
	}
	return 0;
}

 

Code two:     emmm....和上面没什么不同  就是用函数  isdigit( ),isalpha( )...我就是想提醒一下自己~怎么简便怎么使用嘛~

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main() {
	int n;
	cin>>n;
	getchar();
	for(int i=1; i<=n; i++) {
		int q1=0;///alphabet
		int q2=0;///num
		int q3=0;///.
		int q4=0;///no
		string a;
		getline(cin,a);
		int l=a.length();
		if(l<6)
			cout<<"Your password is tai duan le."<<endl;
		else {
			for(int j=0; j<l; j++) {
				if(isdigit(a[j]))
					q2=1;
				else if(isalpha(a[j]))
					q1=1;
				else if(a[j]=='.')
					q3=1;
				else q4=1;
			}
			if(q4)
				cout<<"Your password is tai luan le."<<endl;
			else if(q1&&!q2)
				cout<<"Your password needs shu zi."<<endl;
			else if(!q1&&q2)
				cout<<"Your password needs zi mu."<<endl;
			else if(q1&&q2&&!q4)
				cout<<"Your password is wan mei."<<endl;
		}
	}
	return 0;
}

 

...难受....T_T  说实话,这个题我也就卡多半个小时吧~   嗯...我一点也不生气,不生气....T_T 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值