PAT basic 1081 检查密码 (15分) C++ 测试点2错误解决办法

一、题目描述

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

如果密码合法,输出Your password is wan mei.;
如果密码太短,不论合法与否,都输出Your password is tai duan le.;
如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.;
如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.;
如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

二、代码

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<string>
#include<string.h>
#include<stdlib.h>
using namespace std;
//1081

int main()
{
	int n;
	cin >> n;
	string a;
	getchar();//这里一定得把后面的回车接收掉
	for (int i = 0; i < n; i++)
	{
		bool numflag = false;
		bool chrflag = false;
		bool validflag = true;
		getline(cin,a);
		if (a.length() < 6)
		{
			cout << "Your password is tai duan le." << endl;
			continue;
		}
		else 
			for (int j = 0; j <a.length(); j++)
			{
				if (a[j] >= '0'&&a[j] <= '9')
					numflag = true;
				else
					if ((a[j] >= 'a'&&a[j] <= 'z') || (a[j] >= 'A'&&a[j] <= 'Z'))
						chrflag = true;
					else
						if (a[j] != '.')
							validflag = false;
			}
		if (!validflag)
			cout << "Your password is tai luan le." << endl;
		else if (numflag&&chrflag)
			cout << "Your password is wan mei." << endl;
		else if((!numflag)&&chrflag)
			cout << "Your password needs shu zi." << endl;
		else if((!chrflag)&&numflag)
			cout << "Your password needs zi mu." << endl;
		else
			cout << "Your password needs shu zi." << endl;
	}


	system("pause");
	return 0;
}

三、运行结果

在这里插入图片描述

四、测试点2错误原因及解决方法

测试点2考察的是一行输入中含有空格的情况,遇到这种情况cin是不行的,需要使用getline,getline需要引用string头,getline(cin,a)取一行给a;
同时需要使用getchar()接收上行末尾的回车,这样可以正确通过

题目合集

点这里~

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值