How Many Answers Are Wrong (带权并查集)

http://acm.hdu.edu.cn/showproblem.php?pid=3038

TT and FF are ... friends. Uh... very very good friends -________-b 

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored). 


Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF's question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers. 

Boring~~Boring~~a very very boring game!!! TT doesn't want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose. 

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence. 

However, TT is a nice and lovely girl. She doesn't have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed. 

What's more, if FF finds an answer to be wrong, he will ignore it when judging next answers. 

But there will be so many questions that poor FF can't make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy) 

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions. 

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It's guaranteed that 0 < Ai <= Bi <= N. 

You can assume that any sum of subsequence is fit in 32-bit integer. 

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

题意:有n次询问,给出a到b区间的总和,问这n次给出的总和中有几次是和前面已近给出的是矛盾的

思路: 对于A~B之间的和是S,其实可以理解成B比A-1大S;

Code:

#include<stdio.h>
#include<string.h>
#include<algorithm>
const int N=2e5+10;
using namespace std;
int f[N],rankk[N];
int find(int x)
{
    if(f[x]==-1)
        return x;
    rankk[x]+=rankk[(f[x])];
/// 由于每条边带权,所以把边权更新,
/// 也就是更新间接连接的点;当递归到某一层时
/// x还未连接到根节点上所以rank[x]表示的是x到f[x]的距离;
/// 经上一步操作,f[x]已经接到根节点上了,
/// 即rank[f[x]]表示的是父节点到根节点的距离所以x到根节点的距离就直接
/// 等于rank[x]+rank[f[x]];
    int t=find(f[x]);///我原来是return find(f[x])....一直TLE...然后就用一个变量t
    return f[x]=t;
}
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m))
    {
        memset(rankk,0,sizeof(rankk));
        memset(f,-1,sizeof(f));
        int ans=0;
        int a,b,sum;
        for(int i=0; i<m; i++)
        {
            scanf("%d %d %d",&a,&b,&sum);
            a--;///区间(0,b)分为(0,a-1)和(a,b);
            int fx=find(a);
            int fy=find(b);
            if(fx!=fy)
            {
                f[fy]=fx;
                rankk[fy]=rankk[a]-rankk[b]+sum;
                ///rank[a]表示a到0的和,rank[b]表示a+1到b的和;
                ///rank[fy]表示fx,fy的距离;
            }
            else if(rankk[b]-rankk[a]!=sum)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

!!!~

一直都相信的一句话:

只要不输给过程~就会有好结果!~

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

嵩韵儿

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值