POJ - 3070 -- Fibonacci:【矩阵快速幂基础版】

Fibonacci
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is
在这里插入图片描述
.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

思路

本题是直接给出了构造核心矩阵,如果你不会构造核心矩阵,那这篇文章可能会帮助到你,快速幂与矩阵快速幂以及如何构造核心矩阵

AC代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long ll;
const int MOD=1e4;
struct Mat{
	ll m[2][2];
}arr;
Mat operator *(Mat a,Mat b){
	Mat temp;
	memset(temp.m,0,sizeof(temp.m));
	for(int i=0;i<2;i++)
		for(int j=0;j<2;j++)
			for(int k=0;k<2;k++)
				temp.m[i][j] = (temp.m[i][j] + a.m[i][k] * b.m[k][j] % MOD) % MOD;
	return temp;
}
Mat fast_power(Mat a,ll n){
	Mat res;
	memset(res.m,0,sizeof(res.m));
	for(int i=0;i<2;i++)	res.m[i][i]=1;
	while(n>0){
		if(n&1)	res = res*a;
		a = a*a;
		n>>=1;
	}
	return res;
}
int main(){
	ll n;
	while(scanf("%lld",&n),n!=-1){
		for(int i=0;i<2;i++)
			for(int j=0;j<2;j++)
				arr.m[i][j]=1;
		arr.m[1][1]=0;
		Mat ans=fast_power(arr,n);
		printf("%lld\n",ans.m[0][1]);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值