POJ - 2398 -- Toy Storage【叉积+二分】

Toy Storage
Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza’s parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
在这里插入图片描述
We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.
A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating “Box” on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

题意

给你一个正方形,再给出n个分界线,然后给出m个点,求每个分区落了多少个点。只能包含再内部,边界线以及以外的都不算。

思路

本题是poj–2318的升级版
区别:给出的分界线不是顺序给出的,则需要进行排序,输出也变了。
叉积的运用,存分界线,我们来想一下A点如果在某个分区里面,则一定满足,A在所有左边分解线的逆时针方向,在所有右边分解线的顺时针方向,则可以用二分的思想来解决,结果用map来输出即可。

AC代码
#include<cstdio>
#include<utility> 
#include<cmath>
#include<map>
#include<algorithm>
using namespace std;
const double eps = 1e-6;
const int maxn = 5e3+5;
struct Point{
	double x,y;
	Point(double a = 0, double b = 0){x=a,y=b;}
};
typedef Point Vector;

pair<Point,Point> limit[maxn];
int ans[maxn];
int dcmp(double a,double b){ 
	if(fabs(a-b) < eps){
		return 0;
	}
	return a>b ? 1 : -1;
}
Vector operator - (Point A, Point B){
	return Vector(A.x-B.x, A.y-B.y);
}
double Cross(Vector A,Vector B){
	return A.x*B.y - A.y*B.x;
}
bool operator <(const Point& A,const Point& B){
	if(A.x==B.x)	return A.y < B.y;
	else	return A.x<B.x;
}
bool cheak(int x,int y,int m){
	if(Cross(Point(x,y)-limit[m].first, limit[m].second-limit[m].first) > 0)
		return true;
	return false;
}
int main(){
	int n,m;
	double x1,y1,x2,y2,ui,li;
	while(scanf("%d",&n),n!=0){
		scanf("%d%lf%lf%lf%lf",&m,&x1,&y1,&x2,&y2);
		for(int i=0;i<=n;i++)	ans[i]=0;
		limit[0]=make_pair(Point(x1,y1),Point(x1,y2));
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&ui,&li);
			limit[i]=make_pair(Point(ui,y1),Point(li,y2));
		}
		sort(limit+1,limit+n+1);
		limit[n+1]=make_pair(Point(x2,y1),Point(x2,y2));
		double x,y;
		while(m--){
			scanf("%lf%lf",&x,&y);
			int l=0,r=n+1;
			while(r-l>1){
				int mid=(l+r)>>1;
				if(cheak(x,y,mid))	r=mid;
				else l=mid;
			}
			ans[r-1]++;
		}
		map<int,int> mp;
		for(int i=0;i<=n;i++)
			if(ans[i]!=0)
				mp[ans[i]]++;
		puts("Box");
		for(map<int,int>::iterator it=mp.begin();it!=mp.end();it++)
			printf("%d: %d\n",it->first,it->second);
	 }
	 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

星空皓月

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值