寒假练习——Digit Counting

             

测试样例:

Sample Input
2
3
13

Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1

题目大意:T个测试样例,每个样例给定一个数n,求从1到n的所有数字各个位上0-9出现次数。

AC代码:

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int cnt[10];
int main()
{
  int t;
  scanf("%d",&t);
  while(t--)
  {
      memset(cnt,0,sizeof(cnt));
      int n;
      scanf("%d",&n);
      for(int i=1;i<=n;i++)
      {
          int temp=i;//将数字每一位取出来计数
          while(temp)
          {
              cnt[temp%10]++;
              temp/=10;
          }
      }
      for(int i=0;i<10;i++)//输出格式控制
      {
          if(i<9)
            printf("%d ",cnt[i]);
          else
            printf("%d\n",cnt[i]);
      }
  }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值