问题描述
北航主要办公科研楼有新主楼、逸夫楼、如心楼、办公楼、图书馆、主楼、一号楼等等;。北航网络中心计划要给相关建筑物间铺设光缆进行网络连通,请给出用料最少的铺设方案。
编写程序输入一个办公区域分布图及建筑物之间的距离,计算出用料最少的铺设方案(只有一组最优解,不用考虑多组解)。要求采用Prim或Kruskal算法实现。
输入形式
办公区域分布图的顶点(即建筑物)按照自然数(0,1,2,n-1)进行编号,从标准输入中首先输入两个正整数,分别表示线路图的顶点的数目和边的数目,然后在接下的行中输入每条边的信息,每条边占一行,具体形式如下:
<n> <e> <id> <vi> <vj>
<weight>
…
即顶点vi和vj之间边的权重是weight,边的编号是id。
输出形式
输出铺设光缆的最小用料数,然后另起一行输出需要铺设的边的id,并且输出的id值按照升序输出。
样例输入
6 10
1 0 1 600
2 0 2 100
3 0 3 500
4 1 2 500
5 2 3 500
6 1 4 300
7 2 4 600
8 2 5 400
9 3 5 200
10 4 5 600
样例输出
1500
2 4 6 8 9
样例说明
样例输入说明该分布图有6个顶点,10条边;顶点0和1之间有条边,边的编号为1,权重为600;顶点0和2之间有条边,权重为100,其它类推。其对应图如下:
经计算此图的最少用料是1500,可以使图连通,边的编号是2 4 6 8 9。其对应的最小生成树如下:
代码
// Picture_2.cpp
#include <iostream>
#include<cstring>
using namespace std;
int N, E;
typedef struct ArcNode {
int adjvex;
int weight;
int no;
struct ArcNode* nextarc;
}ArcNode;
typedef struct VNode {
ArcNode* first;
}VNode;
void InsertNode(VNode &G, int no,int adj, int weight) {
ArcNode* temp;
if (G.first == NULL) {
G.first = new ArcNode();
temp = G.first;
}
else {
temp = new ArcNode();
temp->nextarc = G.first;
G.first = temp;
}
temp->adjvex = adj;
temp->no = no;
temp->weight = weight;
}
VNode* G;
void CreatGraph() {
cin >> N >> E;
G=new VNode[N];
for (int i = 0; i < N; i++) {
G[i].first = NULL;
}
for (int i = 0; i < E; i++) {
int no,e1,e2,weight;
cin >> no>>e1>>e2>>weight;
InsertNode(G[e1], no, e2, weight);
InsertNode(G[e2], no, e1, weight);
}
}
void Prime() {
bool* visit = new bool[N];
memset(visit, false, N * sizeof(bool));
visit[0] = true;
int* list = new int[N ];
memset(list, -1, N * sizeof(int));
int count1 = 0;
int sum = 0;
for (int i = 0; i < N; i++) {
int* a = new int[N];
int count = 0;
for (int j = 0; j < N; j++) {
if (visit[j]) {
a[count] = j;
count++;
}
}
ArcNode* temp;
ArcNode* min = new ArcNode;
min->weight = 10000;
for (int j = 0; j < count; j++) {
temp = G[a[j]].first;
while (temp) {
if (temp->weight < min->weight && !visit[temp->adjvex]) {
min = temp;
}
temp = temp->nextarc;
}
}
if (min->weight != 10000)
{
visit[min->adjvex] = true;
list[count1++] = min->no;
sum += min->weight;
}
}
cout << sum << endl;
for (int i = 0; i < N - 1; i++) {
for (int j = 0; j < N - i - 1; j++) {
if (list[j] > list[j + 1]) {
int temp = list[j];
list[j] = list[j + 1];
list[j + 1] = temp;
}
}
}
for (int i = 0; i < N; i++) {
if(list[i]!=-1) cout << list[i] << " ";
}
}
int main()
{
CreatGraph();
Prime();
delete(G);
}