1009 Divisibility

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2613    Accepted Submission(s): 843

 

Problem Description
You are given two 10-based integers b and x, and you are required to determine the following proposition is true or false:

For arbitrary b-based positive integer y=c1c2⋯cn¯¯¯¯¯¯¯¯¯¯¯¯¯¯ (ci is the i-th dight from left of y), define f(y)=∑i=1nci, if f(f(⋯f(y)⋯))∞ can be divided by x, then y can be divided by x, otherwise y can't be divided by x.
 
Input
The first line contains a 10-based integer t (1≤t≤105) — the number of test cases.

For each test case, there is a single line containing two 10-based integers b and x (2≤b,x≤1018).
 
Output
 
For each test case, if the proposition is true, print "T", otherwise print "F" (without quotes).
 
Sample Input
 
1 10 3
 
Sample Output
 
T

题解:

题意:给定 b , x,判断命题:任意一个 b 进制数,如果它是 x 的倍数,那么对它反复进行数位求和,最后的结果也是 x 的倍数。

思路:任意一个b进制数可以写为c1*b^(n-1) + c2*b^(b-2) + ... + cn*b^0,即 c1*b^(n-1) + c2*b^(n-2) + ... + cn(①式),这个b进制数进行反复数位求和的结果为c1 + c2 + ... + cn(②式),以上两个式子同时除以x,如果想要满足题目的条件,则必然是b%x==1,这样的话,①式先将b中是x的倍数的部分先出去,剩下的元素和②式完全相同,也就满足题意了。

#include <iostream>
#include <algorithm>
#include <map>

using namespace std;

typedef long long ll;

int main()
{
    int t;
	scanf("%d",&t);
	while(t--)
	{
		ll b,x;
		scanf("%lld%lld",&b,&x);
		if(b%x==1) printf("T\n");
		else printf("F\n");	
	} 
     
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值