Divisibility (2020 HDU多校联赛)

You are given two 10-based integers b and x, and you are required to determine the following proposition is true or false:

For arbitrary b-based positive integer y=c1c2⋯cn¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯¯ (ci is the i-th dight from left of y), define f(y)=∑i=1nci, if f(f(⋯f(y)⋯))∞ can be divided by x, then y can be divided by x, otherwise y can’t be divided by x
.
Input
The first line contains a 10-based integer t (1≤t≤105) — the number of test cases.

For each test case, there is a single line containing two 10-based integers b and x (2≤b,x≤1018)
.
Output
For each test case, if the proposition is true, print “T”, otherwise print “F” (without quotes).
Sample Input

1
10 3

Sample Output

T

题解

来自多校联赛
在这里插入图片描述
理解上面的,代码就特别简单了

代码:

#include<stdio.h>
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long b,x;
        scanf("%lld %lld",&b,&x);
        if(b%x==1)
            printf("T\n");
        else
            printf("F\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值