PAT-1036题解

1036 Boys vs Girls (25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:
For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F−gradeM.If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95
Sample Output 1:
Mary EE990830
Joe Math990112
6
Sample Input 2:
1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

题意:给出男女生的成绩,要求输出女生最高成绩的信息,男生最低成绩的信息,以及两个成绩之差。如果某一项成绩不存在则输出Absent,如果成绩之差不存在则输出NA。
思路:和1006、1028属于同一类型的模板题。一、建立存储信息的结构体。二、设置初始化函数。三、主程序进行输入输出及比较操作。

代码:

#include<stdio.h>
struct node{
	char name[11];
	char sex;//性别信息可以单独用一个局部变量处理,不一定要写在结构体里面
	char id[11];
	int grade;
}fHighest, mLowest, temp;

bool great(node a, node b){
	return a.grade>b.grade;//此处比较函数可以省略
}

void init(){
	fHighest.grade=-1;
	mLowest.grade=101;
}

int main(void){
	init();
	int n;
	scanf("%d", &n);
	while(n--){
		scanf("%s %c %s %d", temp.name, &temp.sex, temp.id, &temp.grade);
		if(temp.sex=='M'){
			if(great(temp, mLowest)==false) mLowest=temp;//两个if可以用&&代替;
		}
		if(temp.sex=='F'){//==写成了=,注意逻辑运算与算术运算 
			if(great(temp, fHighest)==true) fHighest=temp;
		}
	}
	if(fHighest.grade!=-1 && mLowest.grade!=101) printf("%s %s\n%s %s\n%d", fHighest.name, fHighest.id, mLowest.name, mLowest.id, fHighest.grade-mLowest.grade);//参数与值个数不匹配 
	else if(fHighest.grade!=-1 && mLowest.grade==101) printf("%s %s\nAbsent\nNA", fHighest.name, fHighest.id);
	else if(fHighest.grade==-1 && mLowest.grade!=101) printf("Absent\n%s %s\nNA", mLowest.name, mLowest.id);
	else printf("Absent\nAbsent\nNA");
	//对于男生,女生的信息可以单独考虑输出Absent还是成绩。即可以对每一个输出写一个单独的判断语句节省长度,提高效率。
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值