PTA 集合相似度 (天梯赛真题集)

题目要求:
给定两个整数集合,它们的相似度定义为:N​c​​ /N​t​​ ×100%。其中N​c​​ 是两个集合都有的不相等整数的个数,N​t​​ 是两个集合一共有的不相等整数的个数。你的任务就是计算任意一对给定集合的相似度。

输入格式:
输入第一行给出一个正整数N(≤50),是集合的个数。随后N行,每行对应一个集合。每个集合首先给出一个正整数M(≤10^​4​​ ),是集合中元素的个数;然后跟M个[0,10^​9​ ]区间内的整数。

之后一行给出一个正整数K(≤2000),随后K行,每行对应一对需要计算相似度的集合的编号(集合从1到N编号)。数字间以空格分隔。

输出格式:
对每一对需要计算的集合,在一行中输出它们的相似度,为保留小数点后2位的百分比数字。

输入样例:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

输出样例:

50.00%
33.33%

想法一:用set交集与并集函数求出相对应的个数,结果,运行超时……

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N;
    scanf("%d",&N);
    set<int> num[N+1];

    for(int i=1; i<=N; i++)
    {
        int temp;
        scanf("%d",&temp);
        for(int j=0; j<temp; j++)
        {
            int ttemp;
            scanf("%d",&ttemp);
            num[i].insert(ttemp);
        }
    }

    scanf("%d",&N);
    for(int i=0; i<N; i++)
    {
        set<int> jiaoji;
        set<int>  bingji;

        int numa,numb;
        scanf("%d%d",&numa,&numb);

        //交集
        set_intersection(num[numa].begin(),num[numa].end(),num[numb].begin(),num[numb].end(),inserter(jiaoji,jiaoji.end()));
        int jiaoji_num = jiaoji.size();
        //并集
        set_union(num[numa].begin(),num[numa].end(),num[numb].begin(),num[numb].end(),inserter(bingji,bingji.end()));
        int bingji_num = bingji.size();

        float res = (float)jiaoji_num/bingji_num*100.0;
        printf("%.2f%\n",res);
    }
    return 0;
}

看了别人的代码后,
想法二:自定义方法求结果,只要求出交集,再用总数减去就是并集,结果,运行超时……

#include <bits/stdc++.h>

using namespace std;

float compute(set<int> a, set<int> b)
{
    set<int> ts;
    set<int>::iterator it;
    for(it = a.begin(); it != a.end(); it ++)
    {
        ts.insert(*it);
    }
    for(it = b.begin(); it != b.end(); it ++)
    {
        ts.insert(*it);
    }
    return (a.size() + b.size() - ts.size()) * 100.0 / ts.size();
}

int main()
{
    int N;
    scanf("%d",&N);
    set<int> num[N+1];  

    for(int i=1; i<=N; i++)
    {
        int temp;
        scanf("%d",&temp);
        for(int j=0; j<temp; j++)
        {
            int ttemp;
            scanf("%d",&ttemp);
            num[i].insert(ttemp);
        }
    }

    scanf("%d",&N);
    for(int i=0; i<N; i++)
    {
        int numa,numb;
        scanf("%d%d",&numa,&numb);
        printf("%.2f%\n", compute(num[numa],num[numb]));
    }

    return 0;
}

最后,结合第一和第二的思想,省掉交集函数,终于AC过去了o(* ^ @ ^ *)o

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int N;
    scanf("%d",&N);
    set<int> num[N+1];

    for(int i=1; i<=N; i++)
    {
        int temp;
        scanf("%d",&temp);
        for(int j=0; j<temp; j++)
        {
            int ttemp;
            scanf("%d",&ttemp);
            num[i].insert(ttemp);
        }
    }

    scanf("%d",&N);
    for(int i=0; i<N; i++)
    {
        set<int> jiaoji;
        set<int>  bingji;

        int numa,numb;
        scanf("%d%d",&numa,&numb);

        //交集
        set_intersection(num[numa].begin(),num[numa].end(),num[numb].begin(),num[numb].end(),inserter(jiaoji,jiaoji.end()));
        int jiaoji_num = jiaoji.size();
        //并集
        int bingji_num = num[numa].size() + num[numb].size() - jiaoji_num;;

        float res = (float)jiaoji_num/bingji_num*100.0;
        printf("%.2f%\n",res);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值