ZCMU-2065-打印十字图

Description

在这里插入图片描述

Input

一个正整数 n (n<30) 表示要求打印图形的层数。

Output

对应图形

Sample Input

1

Sample Output

在这里插入图片描述

#include<bits/stdc++.h>

using namespace std;

int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= (n+1)*2; i++){
        if(i==1){
            printf("..");
            for(int j = 1; j <= 4*n+1; j++) printf("$") ;
            printf("..\n");
        }else if(i==2){
            printf("..$");
            for(int j = 1; j <= 4*n-1; j++) printf(".");
            printf("$..\n");
        }else if(i==(n+1)*2){
            for(int j = 1; j <= n; j++) printf("$.");
            printf("..$..");
            for(int j = 1; j <= n; j++) printf(".$");
            printf("\n");
        }else{
            if(i%2==1){
                for(int j = 1; j <= i/2-1; j++) printf("$.");
                printf("$$$.");
                for(int j = 1; j <= 4*n+1-4*(i/2); j++) printf("$");
                printf(".$$$");
                for(int j = 1; j <= i/2-1; j++) printf(".$");
            }else{
                for(int j = 1; j <= i/2-1; j++) printf("$.");
                printf("..$");
                for(int j = 1; j <= 4*n-1-4*(i-2)/2; j++) printf(".");
                printf("$..");
                for(int j = 1; j <= i/2-1; j++) printf(".$");
            }
            printf("\n");
        }
    }
    for(int i = 1; i <= n; i++) printf("$.");
    printf("$$$$$");
    for(int i = 1; i <= n; i++) printf(".$");
    printf("\n");
    for(int i = (n+1)*2; i > 0; i--){
        if(i==1){
            printf("..");
            for(int j = 1; j <= 4*n+1; j++) printf("$") ;
            printf("..\n");
        }else if(i==2){
            printf("..$");
            for(int j = 1; j <= 4*n-1; j++) printf(".");
            printf("$..\n");
        }else if(i==(n+1)*2){
            for(int j = 1; j <= n; j++) printf("$.");
            printf("..$..");
            for(int j = 1; j <= n; j++) printf(".$");
            printf("\n");
        }else{
            if(i%2==1){
                for(int j = 1; j <= i/2-1; j++) printf("$.");
                printf("$$$.");
                for(int j = 1; j <= 4*n+1-4*(i/2); j++) printf("$");
                printf(".$$$");
                for(int j = 1; j <= i/2-1; j++) printf(".$");
            }else{
                for(int j = 1; j <= i/2-1; j++) printf("$.");
                printf("..$");
                for(int j = 1; j <= 4*n-1-4*(i-2)/2; j++) printf(".");
                printf("$..");
                for(int j = 1; j <= i/2-1; j++) printf(".$");
            }
            printf("\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值