ZCMU-1310-Collecting Beats is Fun

Description

Cucumber boy is fan of Kyubeat, a famous music game.

Kyubeat has 16 panels for playing arranged in 4 × 4 table. When a panel lights up, he has to press that panel.

Each panel has a timing to press (the preffered time when a player should press it), and Cucumber boy is able to press at most k panels in a time with his one hand. Cucumber boy is trying to press all panels in perfect timing, that is he wants to press each panel exactly in its preffered time. If he cannot press the panels with his two hands in perfect timing, his challenge to press all the panels in perfect timing will fail.

You are given one scene of Kyubeat’s panel from the music Cucumber boy is trying. Tell him is he able to press all the panels in perfect timing.

Input

The first line contains a single integer k (1 ≤ k ≤ 5) — the number of panels Cucumber boy can press with his one hand.

Next 4 lines contain 4 characters each (digits from 1 to 9, or period) — table of panels. If a digit i was written on the panel, it means the boy has to press that panel in time i. If period was written on the panel, he doesn’t have to press that panel.

Output

Output “YES” (without quotes), if he is able to press all the panels in perfect timing. If not, output “NO” (without quotes).

Sample Input

1
.135
1247
3468
5789
5
…1.
1111
…1.
…1.
1

12.1
.2…
.2…

Sample Output

YES
YES
NO

思路就是统计1-9的个数,如果超过2k就输出NO,否则YES。
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define mem(a) memset(a,0,sizeof(a))
#define N 1000000007
 
char s[5][5];
int f[14];
 
int main()
{
    int k;
    while(~scanf("%d", &k)){
        for(int i = 0; i < 4; i++) scanf("%s", s[i]);
        mem(f);
        for(int i = 0; i < 4; i++){
            for(int j = 0; j < 4; j++){
                if(isdigit(s[i][j])){
                    f[s[i][j]-'0']++;
                }
            }
        }
        int flag = 1;
        for(int i = 0; i < 10; i++){
            if(f[i]>2*k){
                flag = 0;
                break;
            }
        }
        if(flag){
            printf("YES\n");
        }else{
            printf("NO\n");
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值