1021 Deepest Root (25 分)

原题

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

结尾无空行

Sample Output 1:

3
4
5

结尾无空行

Sample Input 2:

5
1 3
1 4
2 5
3 4

结尾无空行

Sample Output 2:

Error: 2 components

结尾无空行

思路

用深度优先算法先遍历一遍,看有没有一个以上的联通分量,如果有直接返回,如果没有,就以每个节点为根节点遍历图,计算每次遍历的最大深度。

通过代码

#include <bits/stdc++.h>
using namespace std;
int visited[10001];
vector <vector<int> > g;
int d[10001];
int n;

void dfs(int x,int deep) {
	deep++;
	visited[x] = 1;
    //printf("处理%d:\n",x);
	for (int i = 0; i < g[x].size(); i++) {
		if (visited[g[x][i]] == 0 && g[x][i] > 0) {
            //printf("  处理%d:\n",g[x][i]);
			dfs(g[x][i],deep);
		}
	}
	if (deep > d[x])d[x] = deep;
    //printf("    处理%d时深度是%d\n",x,deep);
	deep--;
}
int main() {
	int node1, node2, k = 0, deepest = 0;
	scanf("%d", &n);
	g.resize(n + 1);
	fill(visited, visited + n + 1, 0);
	fill(d, d + n + 1, 0);
	for (int i = 1; i <= n - 1; i++) {
		scanf("%d%d", &node1, &node2);
		g[node1].push_back(node2);
		g[node2].push_back(node1);
	}
	for (int i = 1; i <= n; i++) {
		if (visited[i] == 0) {
			dfs(i,0);
			k++;
		}

	}
	if (k > 1) {
		printf("Error: %d components", k);
		return 0;
	}
	for (int i = 1; i <= n; i++) {
		fill(visited + 1, visited + n + 1, 0);
		dfs(i,0);
	}
	for (int i = 1; i <= n; i++) {
		if (d[i] > deepest) {
			deepest = d[i];
		}
	}
	for (int i = 1; i <= n; i++) {
		if (d[i] == deepest) {
			printf("%d\n", i);
		}
	}
	return 0;
}

总结

  1. 一开始用了邻接矩阵来存储图,但是总有一个测试用例运行超时,换成邻接表姐ok了。
  2. 下次报看不懂错误时,记得逐个检查变量,有没有写错变量名,比如有没有把整数型变量当做指针使用。
  3. 注意把数组下标当成map用时,究竟是使用了哪一段的元素。
    fill(x, x + n + 1, 0);
    fill(x + 1, x + n + 1, 0);
    fill(x + 1, x + n, 0);
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值