# PAT甲级1005 Spell It Right

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.
Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

中文题目

公司的每个员工都要签到和签退,最先签到的人开门,最后签退的人关门,找出每天开门和关门的人的ID;

每个人签到时间必定早于签退时间;
不存在两个人同时签到/签退;

输入

第一行:M:每天的记录总数;

其余M行:ID:签到人员;签到时间;签退时间
输出

开门人ID 关门人ID

解题思路

遍历数据一遍,将时间转化成量化的秒格式。再进行比较,记录最小和最大的时间的ID

代码

下面展示一些 内联代码片


#include<bits/stdc++.h>
using namespace std;
int main(void){
    int earlyT=INT_MAX;
    int lateT=INT_MIN;
    int num;
    string earlyN,lateN;
    cin>>num;
    for(int i=0;i<num;i++){
        string IDname;
        cin>>IDname;
        int h1,m1,s1,h2,m2,s2;
        scanf("%d:%d:%d:%d:%d:%d",&h1,&m1,&s1,&h2,&m2,&s2);
        int t1=h1*3600+m1*60+s1;
        int t2=h2*3600+m2*60+s2;
        if(t1<earlyT){
            earlyN = IDname;
            earlyT=t1;
        }
        if(t2>lateT){
           lateN = IDname;
           lateT=t2;
        }
        
    }
    cout<<earlyN<<" "<<lateN;
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值