PAT甲级007 Maximum Subsequence Sum

题目

Given a sequence of K integers { N​1​​, N​2​​, …, N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.
Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.
Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.
Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

中文题目

最大公共子序列问题,特殊点在于如果全为负数,则输出结果为0;

解题思路

前人经验:增益法
1,一维数组存储数据。
2,从第一个数起进行累加求和,如果sum>maxsum,更新maxsum和start,last,start_t,last_t;如果sum<0,则说明之前的结果是负增益的,需要舍弃,sum=0,start=list[i+1];last=list[i+1];

代码

下面展示一些 内联代码片

// A code block
var foo = 'bar';
#include<bits/stdc++.h>
using namespace std;
int main(void){
    int num,start,last,start_t,last_t;
    cin>>num;
    bool flag = false;
    int list[10000]={0};
    for(int i=0;i<num;i++){
        cin>>list[i];
        if(list[i]>=0){
            flag=true;
        }
    }
    if(flag==false){
       cout<<0<<' '<<list[0]<<' '<<list[num-1] ;
       return 0;;
    }
    start=last=list[0];
    int maxsum=INT_MIN;
    int sum=0;
    for(int i=0;i<num;i++){
        sum+=list[i];
        if(sum>maxsum){
           maxsum = sum;
           last=list[i];
           start_t=start;
           last_t=last;
        }
        if(sum<0){
            sum=0;
            if(i<num-1){
            start=list[i+1];
            last=list[i+1]; 
            }
            
        }
        
    }
    cout<<maxsum<<' '<<start_t<<' '<<last_t;
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值