Oulipo(字符串hash)

题目链接

Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output
1
3
0

这道题的题目意思就是给你T组数据,每组数据2行,让你统计第一行数据在第二行数据出现的次数。

这道题如果暴力的去解,那么会超时,所以要用Hash去解,使每个字符串变成相应的数字,然后去比较数字大小,就可以了。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef unsigned long long ULL;
const int N = 1000005;
ULL p[N];
char str1[10005];
char str2[N];
ULL h1[N];
ULL h2[N];
ULL get(int l,int r){
    return h2[r] - h2[l - 1] * p[r - l + 1];
}
int main(){
    int t;
    cin>>t;
    while (t--)
        {
            scanf("%s", str1 + 1);
            scanf("%s", str2 + 1);
            int n1 = strlen(str1 + 1);
            int n2 = strlen(str2 + 1);
            for (int i = 1; i <= n1;i++){
                h1[i] = h1[i - 1] * 131 + str1[i] - 'a' + 1;
            }
            for (int i = 1; i <= n2;i++){
                h2[i] = h2[i - 1] * 131 + str2[i] - 'a' + 1;
            }
            p[0] = 1;
            for (int i = 1; i <= n2;i++){
                p[i] = p[i - 1] * 131;
            }
                int cnt = 0;
            // cout << h1[n1] << endl;
            for (int i = 1; i <= n2 - n1 + 1;i++){
                if(str1[1]==str2[i]){
                    if(h1[n1]==get(i,i+n1-1)){
                        cnt++;
                    }
                }
            }
            cout << cnt << endl;
        }
}

道阻且长
自己选的路 跪着也要走完

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值