HDU 5776 sum(鸽巢定理简单题)

题目链接

Problem Description

Given a sequence, you’re asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO

Input

The first line of the input has an integer T (1≤T≤10), which represents the number of test cases.
For each test case, there are two lines:
1.The first line contains two positive integers n, m (1≤n≤100000, 1≤m≤5000).
2.The second line contains n positive integers x (1≤x≤100) according to the sequence.

Output

Output T lines, each line print a YES or NO.

Sample Input

2
3 3
1 2 3
5 7
6 6 6 6 6

Sample Output

YES
NO

这道题的大致意思是给你n个数的序列,让你去判断该序列是否存在连续的数,使得这些和是m的倍数?
这道题运用前缀和,然后去判断这些和%m是否相等,如果相等,这证明两个数之间的序列加起来是m的和。同时我们可以得出n>=m时必定成立,以为%m的数只有m个,而且是[0,m-1],所以当n>=m,时必定存在%m==0或者两个和%m是一样的。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
int a[maxn];
int vis[maxn];
int main(){
	int t;
	cin>>t;
	while(t--){
		memset(vis,0,sizeof vis);
		int n,m;
		cin>>n>>m;
		for(int i=1;i<=n;i++){
			cin>>a[i];
		} 
		int sum=0;
		int flag=0;
		for(int i=1;i<=n;i++){
			sum=(sum+a[i])%m;
			if(sum==0){
				flag=1;break;
			} 
	        if(vis[sum]){
	        	flag=1;break;
			}
			vis[sum]=1;
		}
		if(flag)cout<<"YES"<<endl;
		else cout<<"NO"<<endl;
	}
}

道阻且长
自己选的路 跪着也要走完

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值