7-2 利用类模板,定义数组类,快速排序

定义一个类模板:

template
class Array
{
……
};

具有对数组元素进行排序和求和的功能。在主函数中,从键盘读入若干int型、double型和char型数据,分别对整型数组、双精度数组和字符数组完成所要求的操作。

输入格式:
每行为一个操作,每行的第一个数字为元素类型,1为int元素,2为double元素,3为char类型。若为int型元素,接着输入int数据,若为double元素,接着输入double数据,若为char型元素,三种类型的元素均以0结束。输入-1时表示全体输入结束。

输出格式:
int型、double型数据输出相应数组排序后的数据及数组的和,char型数据输出排序后的数组元素。

输入样例:
在这里给出一组输入。例如:

1 2 3 4 5 6 0
3 a s d e r q w t 0
2 1.1 2.3 5.6 7.8 0
-1

输出样例:
在这里给出相应的输出。例如:

[2,3,4,5,6]
20
[a,d,e,q,r,s,t,w]
[1.1,2.3,5.6,7.8]
16.8

#include <iostream>
using namespace std;
template<typename T>
class Array
{
private:
	int len;//私有成员  长度 
	T* array;//私有成员  自定义类型的一个  指针a 
public:
	Array(T* a, int length) :array(a), len(length) {}
	int Partition(int first, int end) {	//划分
		int i = first, j = end;						//初始化待划分区域

		while (i < j) {
			while (i < j && array[i] <= array[j])j--;		//右侧扫描
			if (i < j) { T temp = array[i]; array[i] = array[j]; array[j] = temp; i++; }//将较小记录交换到前面

			while (i < j && array[i] <= array[j])i++;        //左侧扫描
			if (i < j) { T temp = array[i]; array[i] = array[j]; array[j] = temp; j--; }//将较大记录交换到后面
		}

		return i;
	}
	void QuickSort(int first, int end) {        //快速排序
		int privot;

		if (first < end) {
			privot = Partition(first, end);          //划分,privot是轴值在序列中的位置
			QuickSort(first, privot - 1);				//求解子问题1,对左侧子序列进行快速排序
			QuickSort(privot + 1, end);				//求解子问题2,对右侧子序列进行快速排序

		}
	}
	void print() {
		cout << "[";
		for (int i = 0; i < len; i++) {
			cout << array[i];

			if (i == len - 1)
				cout << "]" << endl;
			else cout << ",";
		}
	}
	void sumarray() {
		T sum = 0;
		for (int i = 0; i < len; i++) {
			sum += array[i];

		}
		cout << sum << endl;
	}

};

int main() {

	int ch = 0;
	int i ;
	
	while (cin >> ch) {
		if (ch == -1)
			break;
		else if (ch == 1) {
			int n = 0;
			int a1[999];
			for ( i = 0;; i++) {
				cin >> a1[i];
				if (a1[i] == 0)
					break;
			
			}
			Array<int>array(a1, i);
			array.QuickSort(0, i-1);

			array.print();
			array.sumarray();
		}
		else if (ch == 2) {
			
		    double a2[999];
			for ( i = 0;; i++) {
				cin >> a2[i];
				if (a2[i] == 0)
					break;
				
			}
			Array<double>array(a2,i);
			array.QuickSort(0, i-1);
			array.print();
			array.sumarray();
		}
		else if (ch == 3) {
			
			char a3[999];
			for (i = 0;; i++) {
				cin >> a3[i];
				if (a3[i] == '0')
					break;
				
			}
			Array<char>array(a3, i);
			array.QuickSort(0, i-1);
			array.print();
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值