PTA 7-5 两点间距离计算

给出下面的一个基类框架:

class Point_1D

{ protected:

float x;//1D 点的x坐标

public:

Point_1D(float p = 0.0);

float distance(const Point_1D & p2);

}

以Point_1D为基类建立一个派生类Point_2D,增加一个保护数据成员:

float y;//2D平面上点的y坐标

以Point_2D为直接基类再建立一个派生类Point_3D,增加一个保护数据成员:

float z;//3D立体空间中点的z坐标

生成上述类并编写主函数,根据输入的点的基本信息,建立点对象,并能计算该点到原点的距离。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(点的类型(1表示1D点,2表示2D点,3表示3D点) 第一个点坐标信息(与点的类型相关) 第二个点坐标信息(与点的类型相关))。当读入0时输入结束,相应的结果不要输出。

输入样例:

1 -1 0

2 3 4 0 0

3 1 2 2 0 0 0

0

输出样例:

Distance from Point -1 to Point 0 is 1

Distance from Point(3,4) to Point(0,0) is 5

Distance from Point(3,3,3) to Point(0,0,0) is 3

#include<iostream>
#include<cmath>
using namespace std;
class Point_1D

{
protected:

	float x;//1D 点的x坐标

public:


	Point_1D(float a) {
		x = a;
	}
	float distance(const Point_1D& p1, const Point_1D& p2) {
		float d = 0.0;
		float t = 0.0;
		t = (p1.x - p2.x)* (p1.x - p2.x);

		d = sqrt(t);
		return d;
	}

};
class Point_2D :public  Point_1D {
protected:
	float y;//2D平面上点的y坐标
public:

	Point_2D(float a, float b) :Point_1D(a) {
		y = b;
	}
	float distance1(const Point_2D& p3, const Point_2D& p4) {
		float d = 0.0;
		float t = 0.0;
		t = (p3.x - p4.x) * (p3.x - p4.x) + (p3.y - p4.y) * (p3.y - p4.y);

		d = sqrt(t);
		return d;
	}
};
class Point_3D :public  Point_2D {
protected:
	float z;//3D立体空间中点的z坐标
public:
	Point_3D(float a, float b, float c) :Point_2D(a, b) {
		z = c;
	}
	float distance2(const Point_3D& p5, const Point_3D& p6) {
		float d = 0.0;
		float t = 0.0;
		t = (p5.x - p6.x) * (p5.x - p6.x) + (p5.y- p6.y) * (p5.y - p6.y)+(p5.z - p6.z) * (p5.z - p6.z);
		d = sqrt(t);
		return d;
	}
};
int main() {
	int ch = 0;

	while (cin >> ch) {
		if (ch == 0)break;
		if (ch == 1) {
			float a,b;
			cin >> a>>b;
			Point_1D p1(a);
			Point_1D p2(b);
			
			cout << "Distance from Point " << a << " to Point "<<b<<" is " << p1.distance(p1,p2) << endl;
		}
		else if (ch == 2) {
			float a, b,c,d;
			cin >> a >> b>>c>>d;
			Point_2D p2(a, b);
			Point_2D p3(c, d);
			cout << "Distance from Point" << "(" << a << "," << b << ")" << " to Point("<<c<<","<<d<<") is " << p2.distance1(p2,p3) << endl;

		}
		else if (ch == 3) {
			float a, b, c,d,e,f;
			cin >> a >> b >> c>>d>>e>>f;
			Point_3D p3(a, b, c);
			Point_3D p4(d, e, f);
			cout << "Distance from Point" << "(" << a << "," << b << "," << c << ")" << " to Point("<<d<<","<<e<<","<<f<<") is " << p3.distance2(p3,p4) << endl;
		}
	}
	return 0;
}
  • 2
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值