PTA:K times in the string (10分)(C语言)

Given a positive integer K and a string (consisting of no more than 100 numbers and letters), you need to find out the first character that appears at least K times.

If such a character does not exist, output No solution .

Sample Input 1:
3 coincidance

Sample Output 1:
c

Sample Input 2:
5 pineapple

Sample Output 2:
No solution

#include <stdio.h>

int main()
{
    char str1[127] = {0};
    char str2[100];
    int k;
    int judge = 0;
    scanf("%d", &k);
    scanf("%s", &str2);
    int i, j;
    for (i = 0; str2[i] != '\0'; i++)
    {
        j = str2[i];
        str1[j]++;
    }
    for (j = 0; j <= 127; j++)
    {
        if(str1[j] == k)
        {
            printf("%c", j);
            judge = 1;
        }

    }
    if (judge == 0)
        printf("No solution");

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值