【C语言做题系列】Deck

A single playing card can be placed on a table, carefully, so that the short edges of the card are parallel to the table’s edge, and half the length of the card hangs over the edge of the table. If the card hung any further out, with its center of gravity off the table, it would fall off the table and flutter to the floor. The same reasoning applies if the card were placed on another card, rather than on a table.

Two playing cards can be arranged, carefully, with short edges parallel to table edges, to extend 3/4 of a card length beyond the edge of the table. The top card hangs half a card length past the edge of the bottom card. The bottom card hangs with only 1/4 of its length past the table’s edge. The center of gravity of the two cards combined lies just over the edge of the table.

Three playing cards can be arranged, with short edges parallel to table edges, and each card touching at most one other card, to extend 11/12 of a card length beyond the edge of the table. The top two cards extend 3/4 of a card length beyond the edge of the bottom card, and the bottom card extends only 1/6 over the table’s edge; the center of gravity of the three cards lines over the edges of the table.

If you keep stacking cards so that the edges are aligned and every card has at most one card above it and one below it, how far out can 4 cards extend over the table’s edge? Or 52 cards? Or 1000 cards? Or 99999?
Input
Input contains several nonnegative integers, one to a line. No integer exceeds 99999.
Output
The standard output will contain, on successful completion of the program, a heading:

Cards Overhang

(that’s two spaces between the words) and, following, a line for each input integer giving the length of the longest overhang achievable with the given number of cards, measured in cardlengths, and rounded to the nearest thousandth. The length must be expressed with at least one digit before the decimal point and exactly three digits after it. The number of cards is right-justified in column 5, and the decimal points for the lengths lie in column 12.
Sample Input
1
2
3
4
30
Sample Output
The line of digits is intended to guide you in proper output alignment, and is not part of the output that your solution should produce.

12345678901234567

Cards Overhang

1     0.500
2     0.750
3     0.917
4     1.042

30 1.997
题意:
一张一张搭扑克牌,输入一个数n,计算出这n张扑克牌所超出桌子边缘的距离。
注意:
此题没有特别的计算公式,需要自己根据数据去找规律。
其次,需要注意的是本题的输出格式,要求较多。

算法思想:
根据题意,手写一下可以简单得到图上规律
根据题意,容易得到上述规律。
上代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
int a[maxn];

int main()
{
    int n;
    double k = 0.5;             //定义一个常数变量
    printf("# Cards  Overhang\n");    //输出特别要求
    while(scanf("%d", &n)!=EOF)       //多组输入
    {
        double sum = 0;         //定义一个数来存储超出桌子边缘的长度

        int i;
        for(i=1; i<=n; i++)      //根据规律算出 第n 张 扑克牌超出桌子边缘的长度
        {
            sum+=k/i;
        }
        printf("%5d%10.3f\n", n, sum); //特别注意输出格式,题目中有相应说明

    }
    return 0;
}

注:此处还有另外一种模式,即找到题目的递推规律,把所有的答案先算出来,再根据n值输出正确答案。
上代码:

#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
double a[maxn];             //定义一个double数组来存储计算出来的答案

int main() {
    int n;
    a[1]=0.5;
    for (int i=2; i<100000; i++)
        {
            a[i]=a[i-1]+0.5/i;           //此为递推公式
        }
    printf("# Cards  Overhang\n");
    while (scanf("%d",&n)!=EOF)          //根据输入的数直接输出答案
        {
            printf("%5d%10.3lf\n",n,a[n]);
        }
    return 0;
}

心得:
通常没有思路的题目不需要刻意去找到一个思路,有时候题目考察的就是找规律,平时一定要准备草稿本喔,还要特别注意输出格式。用到浮点数的地方用double就对了(还有一点,本体样例输出中没有专门的空格,小心入坑)。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值