问题描述
给定一个长度为n的数列,将这个数列按从小到大的顺序排列。1<=n<=200
输入格式
第一行为一个整数n。
第二行包含n个整数,为待排序的数,每个整数的绝对值小于10000。
输出格式
输出一行,按从小到大的顺序输出排序后的数列。
样例输入
5
8 3 6 4 9
样例输出
3 4 6 8 9
上代码:
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e5+5;
int a[205];
int cmp(int a, int b)
{
return a<b;
}
int main()
{
int n;int a[205];int i;
while(scanf("%d", &n)!=EOF)
{
for(i=0;i<n;i++)
scanf("%d", &a[i]);
sort(a,a+n,cmp);
for(i=1;i<n;i++)
printf("%d ", a[i]);
printf("\n");
}
return 0;
}
就是简单的输入,排序,输出。但特别强调的是输出格式,因为这个半天A不了。此处的输出方式值得借鉴。