数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
已知二叉树的一个按先序遍历输入的字符序列,如abc,de,g,f, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input
连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output
输出二叉树的叶子结点个数。

Sample Input
abc,de,g,f,
Sample Output
3
Hint

Source
xam

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *r,*l;
};
char a[55];
int i;
int len;
struct node *creat()//递归建立二叉树//
{
    char c;
    struct node *root;
    c=a[i++];
    if(c==',')
        return NULL;
    else
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->data=c;
        root->l=creat();
        root->r=creat();
    }
    return root;
};
void shu(struct node *root)
{
    if(root)
    {
        if(root->l)
            shu(root->l);
        if(root->r)
            shu(root->r);//递归左右子树//
        if(root->l==NULL&&root->r==NULL)
            len++;//找到一个左右子树为空的节点就加一//
    }
    return;//函数递归终止条件//

}
int main()
{
    struct node *root;
    while(scanf("%s",a)!=EOF)
    {
        i=0;
        len=0;
        root=(struct node *)malloc(sizeof(struct node));
        root=creat();
        shu(root);
        printf("%d\n",len);
    }
    return 0;
}
  • 4
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值