问题1031:统计一个整数中数字的个数

统计一个整数中数字的个数

描述

 

输入一个正整数 repeat (0<repeat<10),做repeat 次下列运算:

读入 1 个整数n(n<10^100),统计并输出n中2 的个数。

输入

 

见sample

输出

 

见sample

输入样例 1

3
-21902
2
345543

输出样例 1

count=2
count=1
count=0
#include <iostream>
#include <string>
#include <cstring>
#include <stdio.h>
using namespace std;

int main()
{
    int repeat,len;
    while(cin>>repeat)
    {
        getchar();
        for(int j=0; j<repeat; j++)
        {
            int coun=0;
            char pa[100];
                cin>>pa;
            len=strlen(pa);
            for(int i=0;i<len;i++)
            {
                if(pa[i]=='2')
                    coun++;
            }
            cout<<"count="<<coun<<endl;
        }

    }
    return 0;
}

进行字符模拟

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值