Codeup_1795:问题 A: Fibonacci

Problem Description

The Fibonacci Numbers{0,1,1,2,3,5,8,13,21,34,55…} are defined by the recurrence:
F0=0,F1=1,Fn = Fn - 1 + Fn - 2,n >= 2
Write a program to calculate the Fibonacci Numbers.

Input

Each case contains a number n and you are expected to calculate Fn.(0 <= n <= 30) 。

Output

For each case, print a number Fn on a separate line,which means the nth Fibonacci Number.

Sample Input

1

Sample Output

1

原题链接

解题思路

  • 状态转移方程:dp[i] = dp[i - 1] + dp[i - 2]

代码实现(C++)

#include <iostream>

using namespace std;

#define maxn 31

int n;
int dp[maxn];

int getDp(int n) {
    if (n == 0 || n == 1)
        return dp[n];
    if (dp[n] == -1)
        dp[n] = getDp(n - 1) + getDp(n - 2);
    return dp[n];
}

int main() {
    for (int i = 0; i < maxn; i++)
        dp[i] = -1;
    dp[0] = 0;
    dp[1] = 1;
    while (~scanf("%d", &n))
        printf("%d\n", getDp(n));
    return 0;
}
  • 5
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值