Ignatius and the Princess IV

题目描述
“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…” feng5166 says.

Can you find the special integer for Ignatius?

输入
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

输出
For each test case, you have to output only one line which contains the special number you have found.

样例输入

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

样例输出

3
5
1

译文描述
“好的,你还不错,嗯……但是你永远都不能通过下一个测试。” feng5166说。

“我先告诉你一个奇数N,然后是N个整数。其中会有一个特殊的整数,在我告诉你所有整数之后,你必须告诉我哪个整数是特殊的整数。” feng5166说。

“但是特殊整数的特征是什么?” 伊格内修斯问。

feng5166说:“整数将至少出现(N + 1)/ 2次。如果找不到正确的整数,我将杀死公主,您也将作为我的晚餐。哈哈哈哈…” 。

您可以找到Ignatius的特殊整数吗?

输入
输入包含几个测试用例。每个测试用例包含两行。第一行包含一个奇数N(1 <= N <= 999999),它表示feng5166会告诉我们的英雄的整数。第二行包含N个整数。输入在文件末尾终止。

输出
对于每个测试用例,您只需要输出一行,其中包含找到的特殊编号。

#include <iostream>
#include <map>
using namespace std;
int main() {
	int n;
	while (cin >> n) {
		map<int, int>mp;
		for (int i = 0; i < n; ++i) {
			int tmp;
			cin >> tmp;
			if (mp.find(tmp) == mp.end())
				mp[tmp] = 0;
			mp[tmp]++;
		}
		for (auto& it : mp) {
			if (it.second >= (n + 1) / 2) {
				cout << it.first << endl;
				break;
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值