给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按GPLTGPLT....
这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT
的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:
GPLTGPLTGLTGLGLL
#include <iostream>
#include <string>
#include <map>
using namespace std;
int main() {
string a;
cin >> a;
map<char, int>count;
for (int i = 0; i < a.size(); ++i)
count[toupper(a[i])]++;
while (count['G'] || count['P'] || count['L'] || count['T']) {
if (count['G']) { cout << "G"; count['G']--; }
if (count['P']) { cout << "P"; count['P']--; }
if (count['L']) { cout << "L"; count['L']--; }
if (count['T']) { cout << "T"; count['T']--; }
}
return 0;
}
#include <iostream>
#include <string>
using namespace std;
int main() {
string a;
getline(cin, a);
int g = 0, p = 0, l = 0, t = 0;
for (int i = 0; i < a.size(); i++) {
if (a[i] == 'G' || a[i] == 'g') g++;
else if (a[i] == 'P' || a[i] == 'p') p++;
else if (a[i] == 'L' || a[i] == 'l') l++;
else if (a[i] == 'T' || a[i] == 't') t++;
}
while (g || p || l || t) {
if (g) { cout << "G"; g--; }
if (p) { cout << "P"; p--; }
if (l) { cout << "L"; l--; }
if (t) { cout << "T"; t--; }
}
return 0;
}