**数据结构实验之二叉树五:层序遍历**

数据结构实验之二叉树五:层序遍历

Problem Description
已知一个按先序输入的字符序列,如abd,eg,cf,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input
输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output
输出二叉树的层次遍历序列。

Sample Input
2
abd,eg,cf,
xnl,i,u,

Sample Output
abcdefg
xnuli

建树过程先对简单,但是经常用到;
层序输出利用了队列的性质,先进先出哈哈哈
而且是边输出边加入队列

#include <bits/stdc++.h>
using namespace std;
char a[88];
int l;

struct node
{
    char data;
    struct node *lc,*rc;
};

struct node *creat()
{
    struct node *root;
    char c;
    c=a[l++];
    if(c==',')
        return NULL;
    root=(struct node *)malloc(sizeof(struct node));
    root->data=c;
    root->lc=creat();
    root->rc=creat();
    return root;
};

void cengxu(struct node *root)
{
    struct node *temp[88];
    int in =0,out=0 ;
    temp[in++]=root;
    while(out<in)
    {
        if(temp[out])
        {
            printf("%c",temp[out]->data);
            temp[in++]=temp[out]->lc;
            temp[in++]=temp[out]->rc;
        }
        out++;
    }
}

int main()
{
   int t;
   struct node *root;
   scanf("%d",&t);
   while(t--)
   {
       scanf("%s",a);
       l=0;
       root=(struct node *)malloc(sizeof(struct node));
       root=creat();
       cengxu(root);
       printf("\n");
   }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值