The Unique MST POJ - 1679(最小生成树)

The Unique MST

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V’, E’), with the following properties:

  1. V’ = V.
  2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E’) of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E’.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string ‘Not Unique!’.
Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

题意: 判断一个图的最小生成树是否唯一,如果唯一输出最小权值,否则输出Not Unique!

思路: 先求一次最小生成树,然后枚举边,如果去掉这条边的最小生成树价值和原来一样,则不唯一。(记得边开大一点)

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;
const int N = 110;

struct node
{
    int x,y,w;
} a[N * N];
int p[N];
int vis[N * N];

bool cmp(node a,node b)
{
    return a.w<b.w;
}

int find(int x)
{
    if(p[x]!=x) p[x]=find(p[x]);
    return p[x];
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof vis);
        memset(a,0,sizeof a);
        memset(p,0,sizeof p);

        int n,m;
        scanf("%d %d",&n,&m);

        for(int i=1;i<=n;i++) p[i]=i;

        for(int i=1;i<=m;i++) scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].w);

        sort(a+1,a+1+m,cmp);

        int sum=0;
        int cnt=0;
        for(int i=1;i<=m;i++)
        {
            int px=find(a[i].x), py=find(a[i].y);
            if(px!=py)
            {
                p[px]=py;
                sum+=a[i].w;
                vis[++cnt]=i;
            }
            if(cnt==n-1) break;
        }

        bool flag=true;
        int ans,res;
        for(int i=1;i<=cnt;i++)
        {
            for(int j=1;j<=n;j++) p[j]=j;
            res=0;
            ans=0;
            for(int j=1;j<=m;j++)
            {
                if(vis[i]==j) continue;

                int px=find(a[j].x), py=find(a[j].y);
                if(px!=py)
                {
                    p[px]=py;
                    ans++;
                    res+=a[j].w;
                }
                if(ans==n-1) break;
            }
            if(ans==n-1 && res==sum)
            {
                flag=false;
                break;
            }
        }

        if(flag) printf("%d\n",sum);
        else printf("Not Unique!\n");
    }
    return 0;
}

原题链接:
vjudge
poj

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值