Bound Found(尺取法)

Bound Found

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: “But I want to use feet, not meters!”). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We’ll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t.

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input
The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output
For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

思路:
尺取法+前缀和

完整代码:

#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;
int n,k,m;
struct node
{
    int sum,c;
}v[100005];
bool cmp(node a,node b)
{
    return a.sum<b.sum;
}
void Swap(int &a,int &b)
{
    int t=a;
    a=b;
    b=t;
    return ;
}
void take(int x)        //尺取法
{
    int l=0,r=1,minn=INF;
    int ll,rr,ans;
    while(l<=n && r<=n && minn!=0)
    {
        int t=v[r].sum-v[l].sum;
        if(abs(t-x)<minn)
        {
            ll=v[l].c;
            rr=v[r].c;
            ans=t;
            minn=abs(t-x);
        }
        if(t>x)
        {
            l++;
        }
        else if(t<x)
        {
            r++;
        }
        else
        {
            break;
        }
        if(l==r)
        {
            r++;
        }
    }
    if(ll>rr)
    {
        Swap(ll,rr);
    }
    cout<<ans<<" "<<ll+1<<" "<<rr<<endl;
}
int main()
{

    while(cin>>n>>k)
    {
        if(n==0&&k==0)
        {
            break;
        }
        memset(v,0,sizeof(v));
        for(int i=1;i<=n;i++)
        {
            cin>>m;
            v[i].c=i;                   //前缀和
            v[i].sum=v[i-1].sum+m;
        }
        sort(v,v+n+1,cmp);
        while(k--)
        {
            int x;
            cin>>x;
            take(x);
        }
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值