HDU-1530 Maximum Clique (最大团问题)

Maximum Clique

Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.
Input
Input contains multiple tests. For each test:

The first line has one integer n, the number of vertex. (1 < n <= 50)

The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number).

A test with n = 0 signals the end of input. This test should not be processed.
Output
One number for each test, the number of vertex in maximum clique.
Sample Input
5
0 1 1 0 1
1 0 1 1 1
1 1 0 1 1
0 1 1 0 1
1 1 1 1 0
0
Sample Output
4
题意
给出一个无向图的邻接矩阵,求其最大团中点的数目。
思路
从1到n枚举第i个点在最大团中,每次对i之后的点进行dfs;dfs函数中传递2个参数,一个为当前搜索的点x,一个为当前团的点数目cnt,每次进入dfs时用cnt更新为所搜索过的团的最大点数ans,之后对x之后的每个点i进行遍历,检查每个点与当前集合中的点是否都有边相连,若有则将其加入集合并继续dfs(i,cnt+1),再回溯将其移除集合,以免影响下一个i。
代码

#include<bits/stdc++.h>
using namespace std;

const int N=55;

bool g[N][N];
vector<int> v;
int n;
int ans;

bool check(int x) {
	for(auto i: v)
		if(!g[i][x]) return 0;
	return 1;
}

void dfs(int x,int cnt) {
	ans=max(ans,cnt);
	for(int i=x+1; i<=n; i++) 
		if(check(i)) {
			v.push_back(i);
			dfs(i,cnt+1);
			v.pop_back();
		}
}

int main() {
	while(scanf("%d",&n)) {
		if(n==0) break;
		ans=0;
		for(int i=1; i<=n; i++)
			for(int j=1; j<=n; j++)
				scanf("%d",&g[i][j]);
		for(int i=1; i<=n; i++) {
			v.push_back(i);
			dfs(i,1);
			v.clear();
		}
		printf("%d\n",ans);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值