HDU 1530 Maximum Clique

Maximum Clique

Time Limit: 20000/10000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 88 Accepted Submission(s): 58
 
Problem Description
Given a graph G(V, E), a clique is a sub-graph g(v, e), so that for all vertex pairs v1, v2 in v, there exists an edge (v1, v2) in e. Maximum clique is the clique that has maximum number of vertex.
 
Input
Input contains multiple tests. For each test:

The first line has one integer n, the number of vertex. (1 < n <= 50)

The following n lines has n 0 or 1 each, indicating whether an edge exists between i (line number) and j (column number).

A test with n = 0 signals the end of input. This test should not be processed.
 
Output

            One number for each test, the number of vertex in maximum clique.
 
Sample Input
5
0 1 1 0 1
1 0 1 1 1
1 1 0 1 1
0 1 1 0 1
1 1 1 1 0
0
 
Sample Output
4
 
Author
题目大意:

给出图,求最大团,我感觉是像二分图中的最小顶点覆盖,但是做法完全不一样。

思路:

进行  dfs  跑,加上剪枝
参考了这篇博客   戳这里
大家可以去看一下 

AC代码:


#include <iostream>
#include <cstring>
#include <cstdio>

using namespace std;

struct MAX_CLIQUE
{
    static const int N=60;

    bool G[N][N];///图
    int n, Max[N], Alt[N][N], ans;

    bool DFS(int cur, int tot)
    {
        if(cur==0)
        {
            if(tot>ans)
            {
                ans=tot;
                return 1;
            }
            return 0;
        }
        for(int i=0; i<cur; i++)
        {
            if(cur-i+tot<=ans)///果 U 集合中的点的数量+1(选择 ui 加入 U 集合中)+Si 中所有 ui 后面的点的数量 ≤ 当前最优值
                return 0;
            int u=Alt[tot][i];
            if(Max[u]+tot<=ans)///如果 U 集合中的点的数量+1+[ui, n]这个区间中能构成的最大团的顶点数量 ≤ 当前最优值,
                return 0;
            int nxt=0;
            for(int j=i+1; j<cur; j++)
                if(G[u][Alt[tot][j]])
                    Alt[tot+1][nxt++]=Alt[tot][j];
            if(DFS(nxt, tot+1)) ///如果更新到底层了  我们已经知道了答案
                  return 1;    ///就不用再更新了,因为当前检索到的已经是最大的答案了,在更新可能会更少了
        }
        return 0;
    }

    int MaxClique()
    {
        ans=0, memset(Max, 0, sizeof Max);
        for(int i=n-1; i>=0; i--)
        {
            int cur=0;
            for(int j=i+1; j<n; j++)
                if(G[i][j])
                    Alt[1][cur++]=j;
            DFS(cur, 1);
            Max[i]=ans;
        }
        return ans;
    }
};

MAX_CLIQUE fuck;

int main()
{
    while(scanf("%d", &fuck.n), fuck.n)
    {
        for(int i=0; i<fuck.n; i++)
            for(int j=0; j<fuck.n; j++)
                scanf("%d", &fuck.G[i][j]);
        printf("%d\n", fuck.MaxClique());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值