贪心E - Clarke and food

题目
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a cook, was shopping for food.
Clarke has bought n food. The volume of the ith food is vi. Now Clarke has a pack with volume V. He wants to carry food as much as possible. Tell him the maxmium number he can brought with this pack.
Input
The first line contains an integer T(1≤T≤10), the number of the test cases.
For each test case:
The first line contains two integers n,V(1≤n≤105,1≤V≤109).
The second line contains n integers, the ith integer denotes vi(1≤vi≤109).
Output
For each test case, print a line with an integer which denotes the answer.
Sample Input
1
3 5
1 3 4
Sample Output
2

Hint:
We can carry 1 and 3, the total volume of them is 5.
题意
总共给n个数据,体积a[i],再给一个体积v,问你最多装几个。
从小到大排序再取。

#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;

int main()
{
	int t;
	long long n, v;
	long long a[100005];
	scanf("%d", &t);
	while (t--) {
		int ans = 0;
		scanf("%lld%lld", &n, &v);
		for (int i = 0; i < n; i++) {
			scanf("%lld", &a[i]);
		}
		sort(a, a + n);
		for (int i = 0; i < n; i++) {
			if (v - a[i] >= 0) {
				v = v - a[i];
				ans++;
			}
			else
				break;
		}
		printf("%d\n", ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值