队长给出了一个序列,想让你帮队长干活,你需要处理如下两种情况。
"C a b c"表示给[a, b]区间中的值全部增加c (-10000 ≤ c ≤ 10000)。
“Q a b” 询问[a, b]区间中所有值的和。
Input
第一行包含两个整数N, Q。1 ≤ N,Q ≤ 100000.
第二行包含n个整数,表示初始的序列A (-1000000000 ≤ Ai ≤ 1000000000)。
接下来Q行询问,格式如题目描述。
Output
对于每一个Q开头的询问,你需要输出相应的答案,每个答案一行。
Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
贴个图(偷笑偷笑)
板子题,建议敲自己写的代码
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<cstdio>
#include<vector>
#include<set>
#include<cstring>
#include<cstdlib>
#include<time.h>
#include<stack>
typedef long long ll;
using namespace std;
const int inf=0x3f3f3f3f;
const int maxn = 1e5+5;
ll a[maxn],c1[maxn],c2[maxn],n,q;
ll lowbit(ll x)
{
return x&(-x);
}
void update(ll i,ll value)
{
ll ans=i;
while(i<=n)
{
c1[i] += value;
c2[i] += ans*value;//c1和c2一起更新
i+= lowbit(i);
}
}
ll query(ll i)
{
ll temp1=0,temp2=0,ans=i;
while(i)
{
temp1 += c1[i];
temp2 += c2[i];
i-= lowbit(i);
}
return temp1*(ans+1)-temp2;
}
int main()
{
ll tmp;
scanf("%d%d",&n,&q);
memset(a,0,sizeof(a));
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
for(int i=1;i<=n;i++)
{
scanf("%lld",a+i);
update(i,a[i]-a[i-1]);
}
int a,b;
char s;
while(q--)
{
getchar();
scanf("%c%d%d",&s,&a,&b);
if(s=='C')
{
scanf("%lld",&tmp);
update(a,tmp);
update(b+1,-tmp);//更新
}
else
{
printf("%lld\n",query(b)-query(a-1));//a------b
}
}
return 0;
}