A Simple Problem with Integers POJ - 3468(线段树+区间修改)

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

线段树区间修改求和板子题

题意:如果输入Q X Y表示询问区间【X,Y】的和,C X Y Z表示把区间【X,Y】上的每个数增加Z;

可以看一下这个博客讲的非常好:https://blog.csdn.net/qq_39826163/article/details/81436440

本题是用结构体来写的

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<iostream>
using namespace std;
#define ll long long
const int Max=100005;
struct cai
{
    int l,r;
    ll sum,lazy,length;
}tree[Max<<2];
void update(int k)
{
    tree[k].sum=tree[k<<1].sum+tree[k<<1|1].sum;
}
void updatedown(int k)
{
    if(tree[k].lazy)
    {
        tree[k<<1].sum=tree[k<<1].sum+tree[k].lazy*tree[k<<1].length;
        tree[k<<1|1].sum=tree[k<<1|1].sum+tree[k].lazy*tree[k<<1|1].length;
        tree[k<<1].lazy+=tree[k].lazy;
        tree[k<<1|1].lazy+=tree[k].lazy;
        tree[k].lazy=0;
    }
}
void build(int k,int l,int r)
{
    tree[k].l=l,tree[k].r=r;
    tree[k].lazy=0,tree[k].length=r-l+1;
    if(l==r)
    {
        scanf("%lld",&tree[k].sum);
        return;
    }
    int mid=(l+r)>>1;
    build(k<<1,l,mid);
    build(k<<1|1,mid+1,r);
    update(k);
}
void U(int k,int x,int y,int z)
{
    if(tree[k].l==x&&tree[k].r==y)
    {
        tree[k].sum+=tree[k].length*z;
        tree[k].lazy+=z;
        return;
    }
    updatedown(k);
    int mid=(tree[k].l+tree[k].r)>>1;
    if(y<=mid) U(k<<1,x,y,z);
    else if(x>mid) U(k<<1|1,x,y,z);
    else
    {
        U(k<<1,x,mid,z);
        U(k<<1|1,mid+1,y,z);
    }
    update(k);
}
ll Q(int k,int x,int y)
{
    if(tree[k].l==x&&tree[k].r==y)
    {
        return tree[k].sum;
    }
    updatedown(k);
    int mid=(tree[k].l+tree[k].r)>>1;
    if(y<=mid) Q(k<<1,x,y);
    else if(x>mid) Q(k<<1|1,x,y);
    else
        return Q(k<<1,x,mid)+Q(k<<1|1,mid+1,y);
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,1,n);
        char s;
        int x,y,z;
        while(m--)
        {
            cin>>s;
            if(s=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",Q(1,x,y));
            }
            else
            {
                scanf("%d%d%d",&x,&y,&z);
                U(1,x,y,z);
            }
        }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值